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XMETAL MARKUP

This document contains examples and instructions for using XMetaL to create Help content
elements.
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GETTING STARTED WITH XMETAL

Think of these example tags as basic building blocks, many of which you can combine and
modify in different ways to suit your needs.

You'll do most of your work in the Tags On View.

-

[E procedural> [ iite> Type Instruction title here {fie)
replace\-‘:ith='n1she|p:_-',-'windc;ws_-'?id=Da1626F?-bEa 1-

4c31-8elc-eeS7cl3eatebzhelp_file_disclaimer’

= notLocalizable» _ glbasuer___ </notLocalizable
Type optional introductory text here <Ipara)

Eite> Optional procedure title

[Estep>step 1. [EpamsType step 1 here.
[Sstepystep 2. [Epara>Type step 2 here|</para)

EHite>See also

[ELnavigationLink>» [=] linkText > Placeholder for an optional See alsa
section, </inkText) [Eur> href='mshelp://windows/?id=00000000-0000-0000-

0000-000000000000° inavigationLink) < irelatedLinks) < Iprocedural) —

<>||:> Ia|0|'ralf'cor]'t'en_i}brocedureJ'f_st'epf_par'a' 1 AL
| g% Uniitiedt

You'll find the elements you want to add on the Insert menu.

Insert | Tools Comment Window Help
Paragraph ! I
= |

¢
|

I =
| Inline Element

i Phrase »
List k.
| Procedure Procedure (with title)

3 Alert Set v Procedure (no title)
1 EAQ Entry [ Exp/col procedure

e Section Step

g Section with expandCollapse
Linl_c...
Art or Embedded Object...
Table...
Table Row:...
1 Element... Ctrl+ Shift+1

Advanced L
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You can also add elements from the Insert Element pane. The options available in this pane
change depending on where your cursor is.

Insert Element. x|
[Used Al
alertInline
codelnline
commandinline
embedObject
ertitylnline
environmant'Varable
glossanyEntryLink
keyCombination
languageKeyword
leadIinPhrase

!':' C%an;ge ' Insert Apply

] »

You can change the attributes of an element in the Attribute Inspector pane.

Attribute Inspector X
procedure

- E =
icond'rtion c:oﬁaps&

rta|:u|ac:e".'l.u"rtl':é

| conditionall|

You can get an approximation of what the finished Help will look like in the Page Preview.
Type Instruction title here
__elbasuer__
Type optional introductory text here

Optional procedure title
1. Typestep1 here.
2, Type step 2 here,

See also
Placeholder for an optional See also section.

2lolBf@ Browser-Preview
o Unitled?

USING TEMPLATES

If you need to create a new file, use a template.
1. On the File menu, click New.
2. Click the MAML tab, click a template, and then click OK.
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Mewy @
General | Journalist - MAML | Meeting |
& & 9 @
Article Colurmn Fal GlogsanT ask In:::tn.u:;.r;\tn:nn:s_te
2 & & & W
Media_wrap... Ouick_answer  Shorteut Signpost Stub_ACW
\/
Troubleshoot
’Tl Cancel
PROCEDURES

You can have three different kinds of procedures:
e Basic procedure without title
e Basic procedure with title (included in our Instructions template)
e Expandable procedure
You can also nest a procedure within a procedure or nest a list within a procedure.

Inserting a basic procedure without a title
e Onthe Insert menu, click Procedure, and then click Procedure (no title).
—or—
e Inthe Insert Element pane, double-click procedure.

[El procedure > [E] step ><tep 1. {text} <ipara) </step) < /procedure)

Inserting a basic procedure with title
e Onthe Insert menu, click Procedure, and then click Procedure (with title).

[E] procedure’ [E t'rtle}{ﬁﬂe}
B step>step 1. {text} <Jpara) </step) < /procedure)

Inserting an expandable procedure
¢ On the Insert menu, click Procedure, and then click Exp/col procedure.

] procedure ¥ ewpand Collapse='collapse’

Eite > { title } <Zte)
Estep>step 1. {text} <lpara) < Jstep) < Jprocedure]

The expandCollapse attribute defaults to collapse, which is usually appropriate. You
can change the value to expand, if necessary.
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To change the expandCollapse attribute to Expand

1. Click the expandCollapse attribute to insert your cursor to the left of the opening title
tag.
| e

2. Inthe Attribute Inspector, select the collapse value and an arrow appears. Click the
arrow, and then click expand.

Attribute Inspector *

procedure

address

| condition :

replaceWith |

| conditionalll

Adding a step to any procedure

e Insert your cursor to the right of a closing step tag <&l and then do either of the
following:

o Click the Insert menu, click Procedure, and then click Step.
—or—
o Inthe Insert Element pane, double-click step.
Elstepstep 2. {text} <Ipara)

SECTIONS

A section tag is always contained within a sections tag. A section tag must always contain a
title.

A first-level section tag in a file is the equivalent of a first-level header. You can create multiple
section tags at the same level by adding additional section tags within the sections tag.

If you need subsections within a section (also known as nested sections), you can create one or
more second-level section tags, which are the equivalent of second-level headers, by creating
a new sections tag within any of the first-level section tags, and then adding section tags as
appropriate. If necessary, you can also create third-level sections by following the same logic.
The following procedures describe the basic methods for creating sections.

Inserting a regular section

e Insert your cursor to the right of a closing para tag {Igara)| | click the Insert menu, and
then click Section.

[E sections» [E] section» [2 tﬁle}{ﬁﬁe }

> (texts
Ctite>{ Sidebar title (sidebars are optional) }
(= para»{Sidebar text} <lpara) </sidebar) < /sections)
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This creates a sections tag containing a single section and a sidebar. If you don’'t need
the sidebar, click one of the sidebar tags to select the sidebar, and then delete it.

Note: If you try to insert a section where one is not allowed, XMetaL inserts the section in the
next valid location.

Inserting a nested (regular) section

This method inserts a nested regular section, which is the equivalent of a second-level header.
Don't place a collapsible section within another collapsible section because our editorial rules
don’t allow for the use of nested collapsible sections.

e Insert your cursor between the closing para and section tags |, click the
Insert menu, and then click Section.

[ELsections > (=] section > [ title)>{ title }
(L para> { text}
[ sections > =] section > [ title>{ title }
[ para{ text}
Ctte»{ Sidebar title (sidebars are optional) }
(= para>{Sidebar text} <Jjpara) </sidebar) /zections) < /section) < /sections)

This adds a sections tag containing a single section and a sidebar. If you don’t need the
sidebar, click one of the sidebar tags to select the sidebar, and then delete it.

Inserting an expandable section

e Insert your cursor to the right of a closing para tag <&a3)|, and then do either of the
following:
o Click the Insert menu, and then click Section with expandCollapse.
—or—
o Inthe Insert Element pane, double-click sections.

(= sections > (2 5Eﬁi””>expand(:cllapse='cu:||a|::se'

e { title } <ite)

> (text)
(=L sidebar» (= tile > { Sidebar title (sidebars are optional) } <#te)
[ para» {Sidebar text} <J/para) < /sidebar) </sections)

This creates a sections tag containing a single section and a sidebar. If you don’'t need
the sidebar, click one of the sidebar tags to select the sidebar, and then delete it.

To change the expandCollapse attribute to Expand
1. Click the expandCollapse attribute to insert your cursor to the left of the opening title
tag_ I

2. Inthe Attribute Inspector, select the collapse value and an arrow appears. Click the
arrow, and then click expand.
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| Attribute Inspector ]

|se-:1iu:un

address

| condition

replaceWith

| conditional L

To insert additional sections at the same level

e Insert your cursor between the closing section and sections tags Eacin)| e ||,
the Insert Element pane, double-click section.

[E|Semiuns}"[E|53ﬁi°”>expandCcllapse='n:|:IIa|::5E'
> {title} @@

> {text) <oaa) ezcion)
ExpandCcIIapse='cu:||a|::se'

(it > { title }- <fite)

(= para > { text} < Jpara) </section) < /sections)

EXPANDABLE FAQ ENTRIES

Our FAQ template includes two expandable question and answer sets with a default value of
collapse.

Efag> Httler Type FAQ title here

(=L introduction > (=] para> Type optional introduction text here, </para) < /introduction)
ExpandCcIIapsE='cc|Iapse'

(=L question> (=] para)> Type question 1 here </para)

(£ answery» (2] para>Type answer 1 here </para) < /answer) < /fagEntry)
ExpandCu:lIapse='|:|:||apse'

(= question > (=] para> Type question 2 here </para)

[E answer: (2 para}Type answer ? here </para) < /fanswer] < /fagEntry)

Adding a question and answer set

e Put your cursor to the right of a closing fagEntry tag, and then do either of the following:
o0 Click the Insert menu, and then click FAQ Entry.

o Inthe Insert Element pane, double-click faqEntry.
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ExpandCcIIapse='n:|:IIa|:sE'
(= question’> (= para>» { Question text}

[=Lanswer > [=] para»{ Answer text} </para) </answer) < /fagEntry)

TABLES

Tables can have headings across the top row, headings down the left-hand column, or both.

e Summary: The <summary> element is required and is automatically included in tables
created with our templates. Replace the placeholder text with a summary that will briefly
describe the purpose of the table for screen readers. It won’t be visible in the rendered
file. {summary} {/summary)

e Title: The title is optional.

Inserting a table with a top header row
1. Onthe Insert menu, click Table.
2. Inthe Insert Table dialog box, in the Table style box, click Table with header row.
3. Enter the number of rows and columns, and then click OK.

Esimmeny> {summary ) <Zaimmar)]
=] tableHeader

=] headerEntry
Epare> {text} o)
fheaderEntry)
] headerEntry.
o (text} )
/headerEntry,
ftableHeader,
[Erow > (Hentry > [ para> {text}

o> (text)
Erow> Eenty> Fpera> {text) LGeniry)

Eoas (text) D)

Inserting a table with both top row and left column headers
1. Onthe Insert menu, click Table.

2. Inthe Insert Table dialog box, in the Table style box, click Table with header row and
column.

3. Enter the number of rows and columns, and then click OK.
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(> sy > { summary + <fsimmeny)
(e {rext} 223
e { text) )

JtheaderEntry]
MtableHeader

Elpare> {text}

fheaderEntry]

| Epara> {text}

> Crhesgeny>
B> {text}

fheaderEniry]

e
e {text} )

Adding an introduction to any table

e Insert your cursor to the right of a closing summary tag &) | the Insert Element
pane, double-click introduction.

[=lintroduction > [=] para » { text} </para) < fintroduction)

Adding atitle to any table

e Insert your cursor to the right of the opening table tag EEEE>| | the Insert Element
pane, double-click title.

(Eiie> {title }

Adding arow to any table

e Insert your cursor to the right of a closing row tag Zewll on the Insert menu, click
Table Row.

e Insert your cursor to the right of a closing row tag <=9l |n the Insert Element pane,
double-click row.

LISTS

Lists can be numbered (ordered) or bulleted (unordered). Both types of lists can have an
additional list “nested” within them to create a second level, which does not have to match the
first level in terms of being bulleted or numbered.

Inserting a numbered (ordered) list
e On the Insert menu, click List, and then click Ordered List.

class='crdered'
1. [Elisttem;: (= para>{ text}

2. [Elisthem;> [Epara> {text}




Portfolio of Tricia Spicer Bekey: Writing Sample Page 10 of 13

Inserting a bulleted (unordered) list
e Onthe Insert menu, click List, and then click Unordered List.
—or—
e Inthe Insert Element pane, double-click list.

class='ur~|:rdered'
. Clistien (o[RS <o) <sken)

» [Elsttem> [Fpara> {text}

Inserting a nested list

To add a second level to your list, insert a second list within your list. The second list is
considered “nested.”

e Insert your cursor between a closing para tag and a closing listitem tag <lpara)| <Jisfiem)
On the Insert menu, click List, and then click Unordered List or Ordered list.

class='uncrdered'
+ [T listhtem [E para F{text}

+ [Slisttem> [J para > { text}

class='uncrdered'
+ [Slisthem)> [ para > {text}

. D> Tpaa>{text}

Adding an item to any list

e Insert your cursor to the right of a closing listitem tag Tstten)| and then do either of the
following:
0 Onthe Insert menu, click List, and then click List Item.
—or—
o Inthe Insert Element pane, double-click listltem.

ALERT SETS (NOTE/TIP/WARNING)

Every alert set must have a title (i.e., Note, Notes, Tip, Tips, Warning, or Warnings). The
class and title must match (e.g., if the class is note, the title must be Note or Notes).

Inserting a note, tip, or warning

e Onthe Insert menu, click Alert Set, and then click the type of alert set (Note, Tip, or
Warning).

=l alertSet > ojazs="note’

[t >Note i)
+ [Hakr [Zparay{text} </para) <jalked) </alertSet)
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Adding an additional item to a note, tip, or warning (multiple entries)

1. Insert your cursor to between the closing alert tag and the closing alertSet
tag “CED|<EEMSE) | the Insert Element pane, double-click alert.

=l alertSets class="note’

[ite > N ote ile]
. CEE> O (text) ) G
+ ([Ealket [Cpara» {Text} <para) <Jjaler) < /alkertSet)

2. Manually change the title to a plural (e.g., change Note to Notes). The class stays
singular.

[EalertSet> cjass="note’
[Tt Note g <fite)

NAVIGATION LINKS AND SHORTCUTS

Adding a See also placeholder

Some templates include a See also placeholder that you can use to link to other Help topics. To
add a See also section:

e Insert your cursor to the left of the closing tag of the template (e.g., /procedural,
ltutorial, /faqg). In the Insert Element pane, double-click relatedLinks.
Eehtedtis > (THe>See Also i)

(E navigationLink (=l inkText>» {15t Topic title} <7inkText) [Eur>href="mshelp://windows/?id=1sttopicGUID'

InavigationLink SlinkText> {2nd Topic title} <JinkText) (EUi> href='mshelp://windows/?id=2ndtopicGUID' InavigationLink
IrelatedLinks)|

Modifying a link in a See also placeholder
Once you have a See also placeholder, you need to create the links to each topic.

1. Replace the placeholder text between the linkText tags with the link text that should
appear in the topic (this is usually the title of the linked topic).

2. Click anywhere between the opening and closing uri tags and the current href value
appears in the Attribute Inspector: mshelp://windows/?id=00000000-0000-0000-0000-
000000000000.

3. Copy the GUID of the topic you want to link to from any other source and paste it over the
zeros in the href field of the Attribute Inspector. The href value should begin with
mshelp://windows/?id= and then be followed by the GUID with no spaces in between.

4. Repeat these steps for each topic you want to link to.

Adding a link to another Help topic
1. On the Insert menu, click Link. The Insert Link dialog box appears.
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'E Insert Link @‘

L0 [ (Intertopic Navigation v

Link text: |

Href. mshelpifiwindows/?id=

GUID:

0K Cancel

-

2. Inthe Link type list, select Intertopic Navigation.

3. Inthe Link text box, type the link text that should appear in the topic (this is usually the
title of the linked topic).

4. Copy the GUID of the topic you want to link to from any other source and paste it in the
GUID box. Click OK.

[Epara»For more information, see (2 navigationlink » [EinkText > This s an example </inklext) [Eur>href='mshelp://windows/?id=00000000-0000-
0000-0000-000000000000° |- ¢JnavigationLink) </para)

Adding alink to a website
1. Onthe Insert menu, click Link. The Insert Link dialog box appears.

[ 5 Insert Link @‘
Link bpe: -
Link text: |
Href: http:iigo.microsoft. comifwlink!?linkid=
GUID: |
Alt Text: |
OK Cancel

2. Inthe Link type list, select Web Navigation.

3. Inthe Link text box, type the link text that should appear in the topic (this is usually the
title of the linked webpage).

4. Inthe GUID box, insert the FWLink code.
5. Inthe Alt Text box, enter the summary text, and then click OK.

(=L navigationLink > [=] linkText> This

HinkText) [Eun> href="http://go.microsaft.com/fwlink/?
linkid=00000' [E summany>This is the summar\,r textw

£ Juri) .fnawgatu:lnLln k)
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Note: For more information on acquiring FWLink code and summary text guidelines for
FWLinks, see the Style Guide.

Adding a shortcut to a program (ShellExecuteLink)
1. Onthe Insert menu, click Link. The Insert Link dialog box appears.

Q Insert Link léj
Link ype: .
Link text: ]
Exec ] app.exe
Command
Alt Text: I
OK Cancel

In the Link type list, select Shell Execute.

In the Link text box, type Click to open <name of item>.

In the Exec Command box, insert the shell execute code.

In the Alt Text box, enter the summary text for the screen reader, and then click OK.

[2 shellExecutelink > (=] inkText > Click to open the Program Compatibility troubleshooter, < /finkText,

(=] command > 9,255y stemroot%25\system32\msdt.exe -id PCWDiagnostic < /command)
(= summary>> Click to open the Program Compatibility troubleshooter </summary) <jshelExecutelink)

Note: For more information on acquiring shell execute code and summary text guidelines
for shell executes, see the Style Guide.

a s wn
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